Menu
Cart

Multilingual Settings

Multilingual Settings
Multilingual Settings
Multilingual Settings
Multilingual Settings
Multilingual Settings
Multilingual Settings
Multilingual Settings
Multilingual Settings
Multilingual Settings
Multilingual Settings
Multilingual Settings
Multilingual Settings
Multilingual Settings
3.x 2.x 1.x
Multilingual Settings
Multilingual Settings
Multilingual Settings
Multilingual Settings
Multilingual Settings
8 more

Description

By default, opencart settings do not support multilingualism. This becomes a problem when using several languages on the site, because you need to specify a lot of important information in different languages: SEO data, contacts, and often the logo.

The Opencart module Multilingual Settings will help to solve this problem.
The new version 3.0, compared to previous versions, has a completely different approach to implementing multilingual opencart settings. Multilingual Settings 3.0 is a separate module with minimal system interference.

Important! Multilingual Settings 3.0 only supports Opencart 2.3 and Opencart 3.0.x.

What fields the module will help to make multilingual:

  • Title meta tag
  • Meta Title
  • Meta Tag Description
  • Meta Tag Keywords
  • Store Name
  • Store Owner
  • Address
  • Geocode
  • E-Mail
  • Telephone
  • Fax
  • Image
  • Opening Time
  • Comment 
  • Store Logo

During installation, the module will automatically copy the existing field values. The module supports multi store.
 

Description for old versions

The Multilingual Settings is an OCMOD extension for Opencart 3.x, 2.x, 1.5.x. Some fields of system settings of Opencart will become multilingual with it.

Opencart 3.x is supported now!

Supported fields:

  • Meta Title
  • Meta Tag Description
  • Meta Tag Keywords
  • Store Name
  • Store Owner
  • Address
  • Geocode
  • E-Mail
  • Telephone
  • Fax
  • Opening Time
  • Comment

Moreover, the Telephone field is increased up to 64 characters.

Warning! If you have an error Array to string conversion, please write us.


Version History

3.0 (18/03/2021)

The base code of the module has been created in the Opencart Modules Generator.

What's New in Multilingual Settings 3.0:

  • the module has its own settings interface;
  • a completely different algorithm, due to which compatibility with other additions should be much higher;
  • interventions in the opencart code are minimal. The new version does not have a large and complex modification;
  • added support for Image and Store logo fields;
  • the version 3.0 only supports opencart 2.3 and openacrt 3.0.x.


How to upgrade if you have the old version of Multilingual Settings installed:

  1. Install the module using the opencart installer.
  2. Enable and configure the module. The first time you turn it on, the module will copy the existing settings.
  3. Go to the list of modificayions and disable the old version. If the modification was installed in the /system folder - delete the mod or rename it.
  4. Update the modifications cache.
  5. Clear theme cache (for opencart 3).

Reviews

Write a review

Note: HTML is not translated!
Bad Good
Captcha
Multilingual Settings
$9.99

Available Options

Does not change or replace files
Does not require IonCube Loader
Clean and clear code
Unlimited support
Demo
Admin areademo.helpforsite.com/3032/admin
Login: demo
Password: demo
Requirements
PHP version5.4+
OCMOD (OC 2 only)OCMOD multiline fix
OCMOD fix error skip
vQmod (OC 1.5 only)2.5+
Compatibility
OpenCart version1.5.x, 2.x, 3.0.x
Other
Interface LanguageUA, EN, RU